raspberry pi 上的pulseaudio

ps3 eye有时可以工作,有时就不能工作,一直郁闷了好几周找不着问题.最终经过排查了几周是pulseaudio 版本过低的问题.raspberry pi官方的镜像中pulseaudio非常旧,还停留在5.0.
中间过程曲折,首先下载的最新的官方镜像测试,一直有问题,时好时坏.然后过元旦的第一天下载了ubuntu镜像,pulseaudio版本是8.0.非常ok没有问题,但是ubuntu的桌面非常慢,导致打开个网页也卡的不行,然后就在另外一个raspberry pi3上测试自己编译高版本的pulseaudio,参考:
http://youness.net/raspberry-pi/bluetooth-headset-raspberry-pi
这位大神的文章,最终编译成功,时好时坏的现象没有了非常稳定。

简明过程如下:

apt-get update
apt-get upgrade
apt-get install intltool libtool libcap-dev libjson0-dev libsndfile1-dev
apt-get install libudev-dev libsbc-dev libbluetooth-dev libx11-xcb-dev libasound2-dev instal libsystemd-dev libsamplerate0-dev
wget 'https://freedesktop.org/software/pulseaudio/releases/pulseaudio-9.0.tar.gz'
tar zxvf pulseaudio-9.0.tar.gz
cd pulseaudio-9.0
./bootstrap.sh
make
make install
ldconfig

中间过程总是被老婆笑话,”你的智能家居好了没呀?”,”都搞了好几周。还没搞定。”,”连个麦克风都搞不定,行了别玩了。”

好吧,别笑话哥,哥已经搞定了,继续下边的工作。。。